Systems Update

Supported Browsers and Operating Systems

On January 8, 2018, we’ll be upgrading our website to make it as safe as possible and align with industry standards and best practices. Because of this, you may need to upgrade from older Operating System versions and browsers to a version capable of supporting TLS 1.2.

You can check your browser’s TLS compatibility here by selecting “Test your browser”. If you do not upgrade, you will get a connection error when attempting to access our site.

Browsers & Operating Systems 

TLS 1.2 Compatibility Notes

Microsoft Edge

Compatible by default

Microsoft Internet Explorer Desktop and mobile version 11 

Compatible by default

Microsoft Internet Explorer Desktop version 9 and 10

Capable when run in Windows 7 or newer

Firefox 27 and higher

Compatible by default

Google Chrome 38 and higher

Compatible by default

Mobile Safari versions 5 and higher   

Compatible by default

Microsoft Windows 7, 8.0, 8.1 and 10

Compatible by default

Microsoft XP/Vista and below  

Not compatible with TLS 1.2